My battery won’t charge - what can I do now?

Follow

Comments

7 comments

  • Heikki Nousiainen

    My meepo v3 shows that there is still 34% of battery left, but the remote says that there isn't any and the board stops, what can I do? I can get about 12 kilometers and then it stops.

    0
    Comment actions Permalink
  • Michael rud

    Sadly no loose wires

    0
    Comment actions Permalink
  • Michael rud

    My battery wont charge. All the connections look fine. I have like 10% left and the board will still run. What can i do?? I tried disconecting and reconnecting everything... thats about the extent of my electrical skills

    0
    Comment actions Permalink
  • Tanner Dugas

    My meepo remote recently stopped charging and it is still under the original 6 month warranty.

    0
    Comment actions Permalink
  • Tanner Dugas

    I have a friend who had the same problem. He had a connector that was broken loose from the soldering. If look around you might be able to find a loose wire and that could be the problem.

    Hope all goes well.

    0
    Comment actions Permalink
  • Matt

    When you plug in the board, does the red screen on the board light up with the battery %? If it doesn't, I'm almost certain it's a loose wire. In the battery compartment, there's two connections with melted yellow plastic over them. Check them thoroughly

    0
    Comment actions Permalink
  • Matt

    Also check there are no loose wires in the battery compartment. I have had to solder a cable back to the circuit board 4 times (Meepo V3), without this cable the board can't charge.

    It's been fine since last time as i melted some silicone over the top of the connection and this distributes the vibrations over a larger area rather than the solder alone.

    0
    Comment actions Permalink

Please sign in to leave a comment.

Powered by Zendesk